Elevated Tab Latency

Incident Report for Windsurf

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 22:02 UTC

Investigating

We're experiencing an elevated level of errors and are currently looking into the issue.
Posted Jul 29, 2025 - 21:48 UTC
This incident affected: Windsurf Tab.