Payment Issues

Incident Report for Windsurf

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 02:33 UTC

Investigating

Some users may experience issues with checkout and payments due to a disruption with our payment provider. We are actively investigating.
Posted Feb 24, 2026 - 01:38 UTC